Entry point not found issues with cygwin DLLs

Heavenly Avenger avenger@avenger.ws
Mon Jul 2 19:08:00 GMT 2018


First post in the list, I hope I am not mistaken in the place to post 
the question, but let's give it a try.

I'm having hard times with cygwin here, random libraries stop working 
once I update or install new ones.

Today I run 'rebaseall' and it detected a lot of completely missing DLLs 
from packages. So I wrote a script to build up the list of packages that 
contained the DLLs to use setup-x86_64 to reinstall them.

After reinstalling, 'rebaseall' ran without apparent issues. But still 
ssh and perl are unusable.

If I run the ssh client, it simply returns to the command prompt. Perl 
likewise. Passing any commandline parameters does not change it.

If I run ssh with 'strace' ('strace ssh'), it pops up a windows dialog 

'the procedure entry point __memcpy_chk could not be located in the 
dynamic link library c:\cygwin\bin\cygcrypto-1.0.0.dll'

I found this file is located in the 'openssl100-1.0.2o-1' package. The 
file is present and has about 2.3MB in size. I've deleted the package's 
tar from within my local cygwin packages cache and reinstalled. Still 
the same.

With perl I get the same, but the complained file is called 

Maybe I should be looking for that __memcpy_chk from another DLL; it may 
be missing and strace/cygwin informs a misleading DLL name?

I'm using Windows 10 1709 / 16299.248.
cygwin's dll is: cygwin1.dll file version: 2008.0.0.0, version: 2.8.0.

Thanks in advance to whoever has suggestions on how to tackle with this 
issue, it's been plaguing me for months now.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list