octave says WGL_ARB_multisample is missing

Jon Turney jon.turney@dronecode.org.uk
Mon Jul 2 17:13:00 GMT 2018


On 02/07/2018 13:48, William Mitchell wrote:
> prompt> glxinfo
> name of display: localhost:0.0
> libGL error: required WGL extension WGL_ARB_multisample is missing
> libGL error: required WGL extension WGL_ARB_multisample is missing
> Error: couldn't find RGB GLX visual or fbconfig

Thanks.  This is interesting.

It seems that your graphics card doesn't support WGL_ARB_multisample, 
but does support WGL_ARB_framebuffer_sRGB, which seems a bit unusual.

I've built an libGL1 with a change to handle this situation better [1]

If you download that, chmod +x it, and replace /usr/bin/cygGL-1.dll with 
it (keep a copy of the existing version), you can try 'glxinfo' and 
plotting with octave, to see if it improves things.

[1] ftp://cygwin.com/pub/cygwinx/x86_64/cygGL-1.dll

-- 
Jon Turney
Volunteer Cygwin/X X Server maintainer

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list