latest lighttpd (1.4.45) not working on Windows 10 Home Edition

Alejandro Benitez
Fri Dec 7 14:14:00 GMT 2018


I'd like to add more information to the report.

With the help of the IRC support channel I've managed to successfully 
run a build of a later version of lighttpd (v 1.4.52) which is the 
latest tarball available at

with the following build configuration

`./configure --without-bzip2 --with-openssl --with-lua`

The build is quite identical to the Cygwin build; I did not have to 
tweak my configuration files and everything worked as expected, whereas 
the current Cygwin package (v 1.4.45) shows the behavior I previously 

Best regards,

El 29/11/2018 a las 11:31 a.m., Alejandro Benitez escribió:
> Hi,
> Id like to share that the latest Cygwin lighttpd package does not work
> for me on Windows 10 Home Edition. Neither 32-bit nor 64-bit package. I
> had the chance to test it on both architectures because when I first ran
> into this problem I was running Windows 10 32-bit on this AMD64 PC, but
> later on I did a fresh install of Windows 10 64-bit; the reason for the
> architecture mismatch was that PC vendor sold AMD64 PCs with Windows 7
> Starter Edition (which was 32-bit only IIRC).
> Back to lighttpd: the previous version (1.4.41) does run OK with the
> same config files.
> I suspected the newer lighttpd might have been somehow incompatible with
> v 1.4.41 config files, but I have another machine with Windows 7 64-bit
> and v 1.4.45 does run OK with similar config files.
> The error is non verbose: when I try to load any web page (static or
> PHP) the browser just remains *loading* for a long time and later ends
> with a timeout error page, whereas the previous lighttpd binary just
> loads the page fast. There are no logs written in access.log error.log
> or cygrunsrv.log files.
> I'm not sure, but I'd guess it's a compatibility issue with Windows 10.
> I have mod_access, mod_redirect, mod_rewrite, mod_magnet, mod_proxy,
> mod_fastcgi (for PHP integration) enabled.
> I tried accessing it at every ip (, lan ip and internet ip)
> where the previous version succeeds, to no avail.
> The lighttpd (1.4.45) service also takes too long to stop and sometimes
> it just fails to do so.
> I use latest PHP packages for both v 1.4.41 and v 1.4.45 tests.
> I run Windows 10 April 2018 Update or Windows 10 version 1803.
> Thanks in advance,
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list