Problem referencing libraries in tcl 8.6, e.g. fileutil

Marco Atzeri
Tue Aug 7 16:58:00 GMT 2018

Am 07.08.2018 um 17:56 schrieb SImon Conway-Smith:
> I have added the tcl intepreter into my Cygwin (64-bit) installation, but
> when trying to run some code samples using the fileutil library, e.g. the
> foreachLine command, I'm getting 'invalid command name
> "fileutil::foreachLine"'. I've even tried prefixing the command with "tcl::"
> as I had to do for the mathfunc:: library functions, but still get the error
> message. Is there an additional tcl package I need to install, or what?

fileutil is part of tcllib that is not provided as cygwin package

The last upstream version is located at

It includes an installer written in TCL

$ ./installer.tcl
Installing Tcllib 1.19
You have chosen the following configuration ...

Packages:      /usr/lib/tcllib1.19
Applications:  /usr/bin
Examples:      /usr/bin/tcllib_examples1.19

         NROFF:  /usr/man/mann
         HTML:   Not installed.

Is the chosen configuration ok ? y/N:

Disclaimer: I have not tested the installer as I know nothing of TCL


Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list