Strange errors running gcc tests on Cygwin

Daniel Santos
Sun Mar 5 02:49:00 GMT 2017

HAH! Well I hadn't actually subscribed to the mailing list and decided 
to check the archive to see if anybody replied only to the list. (I'm 
subscribed now)

 > In order to test gfortran 7.1 without installing, you will need to copy
 > cyggfortran-4.dll into a folder which is on LD_LIBRARY_PATH. make check
 > uses only the dll paths associated with the active gcc (presumably your
 > bootstrap compiler).

There should be no reason to have to install gfortran.  The gcc 
documentation ( states 
the compiler requirements to be a working ISO C++98 compiler and makes 
no mention of the need for an existing Fortran compiler or libraries.  
This has all been built in the bootstrap.

$ ll $(pwd)/x86_64-pc-cygwin/libgfortran/.libs/cyggfortran-4.dll
-rwxrwxr-x+ 1 daniel None 9124325 Mar  3 19:15 

 > Why not compare your configure and test results
 > against gcc test results posts?

Well, that's the silly thing; when I ran all of this on my patched code, 
I did not get these errors.   I'm planning on re-running them kind-of in 
hopes that I *will* get these errors so that my compare will be clean, 
but to me this is still not good. make check should NEVER be using any 
native compilers or gcc libraries because that would entirely defeat the 
purpose of doing the tests. I would like to understand what it causing 
this.  Perhaps it is some type of regression?  Note that it claims to be 
setting the LD_LIBRARY_PATH with this directory as the second element:

spawn [open ...]
error while loading shared libraries: cyggfortran-4.dll: cannot open 
shared object file: No such file or directory

This further implies that, if it is looking in the local environment for 
a library and not the build tree, then *all* test results could be 
invalid due to it using compilers and libraries locally installed rather 
than from the build tree, which would be very bad -- a regression that 
hides other regressions!

As much as I just want to get my own tests done, I suppose I better 
debug this. *sigh*


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list