Cygwin 2.6.1 32-bit post install failed by /usr/bin/perl.exe

Katsumi Yamaoka
Mon Jan 16 07:29:00 GMT 2017


I recently tried newly install Cygwin 2.6.1 on 32-bit Windows 10.

I did:
Stop old cygwin
cd c:\
ren cygwin cygwin.old
Run setup-x86.exe for full install excluding *x86_64* modulues.

However, the post install didn't seem to end.  At that time, ps
on mintty showed a lot of defunct perl processes.  Then I tried
replacing /usr/bin/perl.exe with the one I built from the source
one and a half years ago.

cd /usr/bin
mv perl.exe perl.exe.orig
ln -s /cygdrive/c/cygwin.old/usr/local/bin/perl.exe .

It did the trick!  Now new cygwin is running with no problem!
I don't know what yielded the result.  The file sizes of them
very differ because 5.22.3 was srtipped but 5.22.0 wasn't:

-rwxr-xr-x 1 yamaoka None 12829 Jan 15 12:54 perl.exe.orig*
-rwxr-xr-x 1 yamaoka None 12829 Jan 15 12:54 perl5.22.3.exe

-rwxr-xr-x 2 yamaoka None 71801 Oct 21  2015 perl.exe*
-rwxr-xr-x 2 yamaoka None 71801 Oct 21  2015 perl5.22.0.exe*

But I cannot believe strip broke it.  cygcheck for them didn't
show meaningful difference.  It's a mystery.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list