XFIG uses wrong fonts. Solved

Rodrigo Medina rodrmedina@gmail.com
Sat Feb 25 14:40:00 GMT 2017


I am currently installing a new 64bits distribution of cygwin and an
UBUNTU 16.04 in another machine.
In both cases xfig does not find the ghostscript fonts and all the
texts in the drawings
appear with the same default font, making the application practically
useless. The reason
 is the same: the X server is not aware of the ghostscript fonts, as
it can be checked with
 xfontsel, in spite of the fact that the ghostscript package was
installed. I looked into a
frozen 32 bit cygwin distribution running in WXP. In
/etc/X11/fontpath.d/ a symlink pointing
to the directory that contains the gs-fonts is missing:
 xorg-x11-fonts-urw -> /usr/share/ghostscript/fonts

Setting the symlink solved the problem. I think that this bug could be
related to the
ghostscript fonts being installed before the X server.

Solving the problem with ubuntu was not so easy because of the way
that ubuntu uses for
handling the fonts. What I did was to include the path to locate the
ghostscript fonts in the
fontpath, which in ubuntu 16 is:

That can be done with xset (each time) or permanently by putting a
configuration file in
/usr/share/X11/xorg.conf.d.  That is not enough, one has also to put
inside the gsfonts
directory a fontmap file. I stole the files fonts.dir and fonts.scale
from the cygwin
distribution and everything was OK.

I hope that this comment could be usefull,


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list