Problem with X-sever

Syber Raith
Tue Sep 13 00:14:00 GMT 2016


Using Windows Vista on a 32 bit laptop, I installed cygwin and then the xserver components, xserver, xinit, some fonts and XLaunch.  I setup a few lines in my bash_profile to set the DISPLAY environment variable to ":0.0"  Afer that I tried to get XLaunch to launch from an shell script with a configuration as if I had typed on the command line "XLaunch -run <path_to_config.xlaunch>".  I failed to get XLaunch to startup as desired, it just kept starting up as is the script had only XLaunch in it with out the args.  Anyway, in that process I started up the xserver and exited from it maybe 10 times in the course of a few minutes.

Then I noticed the problem.  That is now when I try to start the xserver with XLaunch the cygwin window become unresponsive and my cpu and memory use goes to 100%.  If I do it soon I can use task master to end the cygwin window that that terminates the problem.  If I wait for a while, then task master becomes unable to to terminate the cygwin window or process.

I first uninstalled and reinstalled XLaunch, and that failed to cure the problem.  Next I uninstalled all X components and reinstalled them, and that failed to cure the problem as well.

Restarting the computed failed to help.  I did how ever notice that I can use startxwin to get the xserver running.  This also has a twist.  After I get the xserver running with startxwin, my x-apps can only be started with the x application menu icon in the system tray.  If I try to start them from the cygwin command line they just say "Can't open display:"

I ran sfc on my machine and found that it had some bad files, although it was unable to repair them all.  I'm at a loss as to how to further that.

The x application window say it's using display 0, which is what I set my bash_profile to set the DISPLAY environment variable for, and that is working properly. 

Also when starting up with startxwin even before this problem there was a message that it is still issuing when it starts:

xauth: (stdin):2:  unknown command "ecfa38af903200c6fb04ea87abf12d2e"

Any help would be appreciated. 

Best regards,


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list