problem building with cmake under cygwin (need clang)

Tue Jul 26 00:45:00 GMT 2016


I am trying to compute the convex hull of a high dimensional space (46D x 2000 rows). 
The qhull app available in cygwin/math is based on relatively old code and runs out 
of memory.

I found another version the is supposed to be able to do higher dimensions.

This version is set up to build with cmake, so I installed cmake in cygwin and ran it as,

cmake ./src

Note, I had to copy CMakeLists.txt into the src directory to get this to work. If I 
don't do that, I get the error,

CMake Error: The source directory 
does not appear to contain CMakeLists.txt.

When I have copied the CMakeLists.txt file into ./src, cmake runs but I get the error,

CMake Error at CMakeLists.txt:11 (message):
   only clang supported currently

this comes from the conditional,

     message(FATAL_ERROR "only clang supported currently")

in CMakeLists.txt.

I have installed clang from cygwin, but I still get the same error. I added the 
following line to CMakeLists.txt,


and I get "GNU" as the value for CMAKE_CXX_COMPILER_ID, at least that is the value if 
I got the syntax correct for the message statement.

It looks like I need to point CMAKE_CXX_COMPILER_ID to clang, but I am not sure how 
to do that. I don't know if the problem is with the CMakeLists.txt file, the way I am 
calling cmake, or with my local cygwin configuration.

Suggestions would be appreciated.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list