core dump on rebaseall

Michael Steiner steiner@acm.org
Fri Feb 26 23:06:00 GMT 2016


On 02/24/2016 08:15 PM, "Larry Hall (Cygwin)" wrote:


   > Did you stop your services before upgrading/rebasing?  Do you have
   > any Cygwin executables or DLLs that aren't part of the distribution?

I did stop all services -- rebaseall actually would complain if i
don't.  The only other non-distro cygwin exec/dll which comes in mind
is that i recompiled unison. However, it was not running at the time.
In fact, one of the tests was a rebaseall while in (non-network) safe
mode, so i'd be rather surprised if any other app or service was
running.

However, above triggered a though: i've previously looked into
rebaseall and tried to briefly isolate the problem by pruning
rebase.lst which created to be fed to rebase. Unfortunately, just
removing lines from the back caused for a while still the core dump
and then eventually complained that some files could not be fixed.
Looking at it again it seems the files which are causing the trouble
are following ocaml files!

< /usr/lib/ocaml/stublibs/dllbigarray.so
< /usr/lib/ocaml/stublibs/dllcamlstr.so
< /usr/lib/ocaml/stublibs/dllgraphics.so
< /usr/lib/ocaml/stublibs/dllnums.so
< /usr/lib/ocaml/stublibs/dllthreads.so
< /usr/lib/ocaml/stublibs/dllunix.so
< /usr/lib/ocaml/stublibs/dllvmthreads.so

with them included, running

rebase   -n -s -8 -b 0x400000000 -o 0 -T /tmp/rebase.lst

coredumps. if i exclude them, then it works!

Looking at https://cygwin.com/cgi-bin2/package-cat.cgi?file=x86_64%2Focaml-base%2Focaml-base-4.02.3-2&grep=ocaml-base
the files, though seem to be offically part of ocaml-base and not
modified (Note also my re-install of cygwin was _after_ doing the
ocaml compilation, so this shouldn't have touched the files).  No
idea, though, how to proceed from here ...

-michael-

On Wed, Feb 24, 2016 at 3:30 PM, Michael Steiner <steiner@acm.org> wrote:
> Hi,
>
> Chasing a vfork issue in emacs prevening on sub-shell or dired on a
> uptodate cygwin install, i followed the FAQ and tried to do a
> rebaseall.  Unfortunately, that resulted in a core dump with the
> rebase.exe.statckdump mentioning a STATUS_ACCESS_VIOLATION problem!  I
> then also noticed, that an update with the latest version of the
> setup.exe also causes a rebase.exe.stackdump in c:\cygwin64!.
> Subsequent attempts rebasing in safe mode or after re-installing
> everything (via setup and click on All until it says re-install) had
> the same problem, as did upgrading cyginw, cygwin-debuginfo and
> cygwin-devel from the current 2.4.1-1 to 2.5.0.4 :-(   [The vfork
> problem in emacs, though, did disappear ..]
>
> I have cygwin running via a few months and didn't change anything in
> the config recently (although i did run setup to update to latest
> version). Unfortunately, i have no idea when setup also caused to
> coredump on rebase. It might have done it already for a while but as
> it doesn't complain, i have no idea when the rebase.exe.stackdump
> started showing up in c:\cygwin64.
>
> I googled for this problem but couldn't find any references to rebase
> itself failing.  Anybody has an idea what's going on and/or how to
> debug or work around?
>
> -michael-
>
> PS: I'm running cygwin on Win 8.1 (64-big); see attached cygcheckout
> for more info.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list