bash completion after equals sign does not work after upgrading to bash_completion 2.1-2

Ken Brown kbrown@cornell.edu
Wed Feb 24 16:50:00 GMT 2016


On 2/24/2016 3:41 AM, Imsieke, Gerrit, le-tex wrote:
> It still works with bash_completion 1.3-1
>
> COMP_WORDBREAKS is the default “ "'><=;|&(:” (the string within “”).
>
> Removing everything in /etc/bash_completion.d did not help
>
> Compared to bash_completion 1.3-1, there is almost nothing in
> /etc/bash_completion.d anyway, and there is no /etc/bash_completion file
> any more.

Right.  bash-completion now uses /usr/share/bash-completion, as you can 
see from

   https://cygwin.com/packages/x86_64/bash-completion/bash-completion-2.1-2

> Moving away my .bashrc (that contains only 'complete -o default make'
> wrt completion and that is symlinked to .bash_profile for some arcane
> reason) didn’t help, either.
>
> The only thing that worked so far (except reverting to bash_completion
> 1.3-1) is to use bash --norc.

That's a pretty clear indication that the problem is caused by something 
in your bash startup files.  And the symlink you mentioned could easily 
be confusing the issue.  Have you tried reverting to the default startup 
files (in /etc/defaults/etc/skel)?

[Achim, /etc/defaults/etc/skel/.bashrc has some outdated comments 
referring to /etc/bash_completion.]

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list