Cygwin unable to resolve hostnames

Corinna Vinschen
Fri Feb 12 09:06:00 GMT 2016

On Feb 11 11:58, Carl-Erik Kopseng wrote:
> I disabled IPv6. No change.
> I pinged my gateway. Went fine, but still ssh fails.
> I tried creating a /etc/resolv.conf with the same contents as the one
> on my mac. Same difference.
> And of course I have tried rebooting my VM. No change.
> I still get
> ssh: Could not resolve hostname Non-recoverable
> failure in name resolution

I don't think this is a generic Cygwin problem.  I can resolve the
hostname just fine:

  $ uname -svr
  CYGWIN_NT-10.0 2.4.1(0.293/5/3) 2016-01-24 11:26
  $ ssh
  The authenticity of host ' (' can't be established.
  RSA key fingerprint is SHA256:ddcghrb6BI6+TVDKDE3Yf+U43v9EL6u7HsNw7Hec+y8.
  Are you sure you want to continue connecting (yes/no)? no
  Host key verification failed.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list