less.exe v481-1 cannot seek to EOF in CRLF file; current cygwin32, Win10 only.

KARL BOTTS kdbotts@usa.net
Tue Feb 2 23:57:00 GMT 2016

This is to close out my earlier bug report.  I think it contains a useful
caveat for others.

I have a very old cygwin installation, which I propagate by updating it on one
machine via setup.exe, and then copying the whole c:/cygwin tree to several
other machines, with tar or rsync.  I have not installed it from scratch for
well over ten years.  After I updated from cyg1.7 to cyg2.3, I started having
various line-ending related problems, particularly from <bash> and <less>.

I reported that here under the subject line of this message, a week or so ago.
 Helmut and Marco kindly tried to reproduce it, and failed.  I inferred from
this that there was something wrong with my ancient installation.  I
reinstalled from scratch on one machine, and the problems were gone.  After
diffing and digging for awhile, I think I found the problem:

My old /etc/fstab, that had not been changed for years and worked under 1.7,
has one non-comment line:

none / cygdrive text,posix=0,user 0 0

The same file in the from-scratch install (after running 'mount -c /') has:

none / cygdrive binary,user 0 0

Also present in my (even more ancient) home dir, is a bash script containing
lines like:

mount -u -t --change-cygdrive-prefix "/"
mount -s -t --change-cygdrive-prefix "/"

Note that the -u, -s and -t options are not supported by cygwin <mount>
anymore.  I dimly remember that, long ago, I would run that script after
copying to a new machine, but I have not done so for years.

So the upshot, I think, is this:

Cygwin _used_ to support the notion of mounting volumes with a "text" option,
which had some effect on how line endings were handled.  I am not sure it was
ever valuable, and I don't remember why I did it, but apparently I did, long

Cygwin no longer really supports the "text" option (you could still set it
with mount -o, but I do not recommend that).  Further, it is no longer needed,
if it ever was, which I doubt.  And with it, some critical apps will suffer
line ending problems.  So don't do that.

I think the Win10 business was a red herring.

Thanks for everyone's help and patience.

Karl Botts, kdbotts@usa.net

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list