upgrades hang forever on 0p_000_autorebase.dash

Maarten Jacobs maarten256@hotmail.com
Mon Feb 1 05:32:00 GMT 2016


This may not be relevant - but I ran into a very similar issue tonight... Setup appeared to "hang" - until I found out that Eclipse was "helpful" and pointing out to me that something had changed in the environment... And it was patiently waiting for my input.

The only problem was that the window was hidden under a stack of other windows.

When you run setup, are you sure there's not some window popped up somewhere - but not to the foreground?


Maarten Jacobs

> To: cygwin@cygwin.com
> From: patrick@spacesurfer.com
> Subject: Re: upgrades hang forever on 0p_000_autorebase.dash
> Date: Sun, 31 Jan 2016 22:45:14 +0000
> Hello,
> It seems that the cygwin setup works fine on one of the machines I tried
> (windows 8.1). However on the other machine I have these issues (even on
> a fresh install). The other machine is a work machine (windows 7). I do
> not have access to the admin user, I run the install from my account.
> However, the machine has some software (possibly avecto) that lets me
> run it with what it calls admin privileges. Whenever I run setup it
> blocks on the 0p_000_autorebase.dash script and I have to kill the dash
> process for setup to finish. Is there any way for me to see the
> stdout/stderr of the script that setup is running?
> regards,
> Patrick
>> Patrick Mackinlay <patrick <at> spacesurfer.com> writes:
>>> It requires user input because the file
>>> /var/cache/rebase/rebase_dyn
>>> is created read only the first time and then the second time a rm
>>> requires user confirmation.
>> When run from setup then rm should not prompt (and it doesn't for my
>> installations), at least not if the permissions on the directory are>
> correct
>> and you always run it under the same UID. I could add a "-f", but...
>> You seem to have some borked ACL on your Cygwin installation (i.e. a>
> fresh
>> installation shouldn't have these) or something's wrong with the UID
>> settings (maybe mopve /etc/passwd and /etc/group files). Do you run
>> setup.exe as administrator? Is this a system-wide or user installation?
>> Also the latest snapshot changes the handling of the Administrator and
>> SYSTEM accounts to resolve some issues with intended vs. effective group
>> rights and ACL mask computation.
>> Regard,
>> Achim.
> --
> Patrick Mackinlay patrick@spacesurfer.com
> http://patrick.spacesurfer.com/ tel: +44.7050699851
> Yahoo messenger: patrick00_uk fax: +44.7050699852
> SpaceReg Limited http://www.spacereg.com/
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list