Trouble installing to UNC path and/or mapped network drive

Andreas Wettergren
Tue Aug 23 14:41:00 GMT 2016

Thanks for your reply, the problem has been resolved, details below and in my previous reply to Erik.

> -----Original Message-----
> From: [] On
> Behalf Of Achim Gratz
> Sent: Monday, August 22, 2016 7:37 PM
> To:
> Subject: Re: Trouble installing to UNC path and/or mapped network drive
> Andreas Wettergren writes:
> > I’m running this as a network user that has full read & write access
> > to the target directory and subdirectories.  This user is also a
> > member of the local administrator group.
> […]
> > I’ve tried to run the setup to an empty network path (no prior cygwin
> > files, just an empty directory) as well, with identical results.
> > Nothing gets written to this directory.
> I think the problem is either the local administrator group (sometimes local
> administrators are expressedly forbidden to do anything on the
> network) or your network user cannot change the DACL on the network
> share (another common setup in large organizations).

Yes, it was something like this (I haven't pinpointed the exact cause yet),
running the setup as the network administrator seem to have done the trick.

> > I’ve also tried to run the install to a local drive on my computer.
> > This works as expected, no problems.
> You could try to move / copy that installation to the network share, then.

I had this in mind as something to try, but I wasn't sure if anything in the installation might get incorrect paths or similar.

> > Finally, this sort of install routine has apparently worked in the
> > past, my colleague tells me this is the way he has updated our Cygwin
> > environment before.  It’s possible he did something slightly
> > differently to what I have done this time though.
> Or meanwhile some new security policy got installed that throws a spanner in
> the works.  If your colleague is still able to update Cygwin, you'll know it's
> some sort of access right you're missing and can work it out from there.

Correct, it was some sort of permissions issue, possibly related to underlying Samba problems (see my reply to Erik for details).
I think this Cygwin account I was using was created for a different purpose
(updating a specific in-house program inside Cygwin), and the full install scenario had not been tested before.

Thanks for your suggestions, much appreciated!

Andreas Wettergren
Translation Support
Amesto Translations

> Regards,
> Achim.
> --
> +<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk
> Blofeld]>+
> Samples for the Waldorf Blofeld:
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

More information about the Cygwin mailing list