Trouble installing to UNC path and/or mapped network drive

Erik Soderquist
Tue Aug 23 14:30:00 GMT 2016

On Tue, Aug 23, 2016 at 10:06 AM, Andreas Wettergren  wrote:
>> Why 32 bit rather than 64 bit in a 64 bit environment?  (more curious than
>> anything else, I don't think this affects the outcome).
> This is partially for historical reasons, and partially because I'm personally not
> 100% sure every client that uses the environment is 64-bit yet.

Valid reasons  :)

>> > To work around this, I mapped a network “drive” in Windows Explorer.
>> > The drive is mapped so that my target directory is Z:\Cygwin.
>> Did you set the drive mapping to be remembered on future logins?  If not, a
>> new instance after privilege elevation may also not have the drive mapping.
>> (Still might not, I've had UAC/network drive mapping problems with other
>> programs as well).  Is disabling UAC and running entirely as local admin to test
>> an option?  For that matter, is installinng on the host the installation is local to
>> an option?
> Good points.
> I got some help from my colleague in the end, and it turns out he ran the install as network administrator after all.
> In hindsight I should have tried this, but his instructions specifically mentioned this "Cygwin" user, so I assumed they were accurate.

Assumptions can be dangerous  ;)

> A detail I forgot to mention is that the network share is not really a Windows share, it's actually on a Samba server.
> (Sorry, I should have mentioned this, but I forgot).

That adds additional twists... I have seen Samba configured (both
accidentally and intentionally) to report "full control" when queried
for what permissions a user has and still have everything locked as
read only for most users.  Windows can now do this from AD Group
Policies as well, but is rarely configured to do so.

> Although at first glance it seems the Cygwin user I was using looks like it has the correct permissions,
> something was obviously missing or incorrectly mapped, running as the network admin worked fine.
> I suspect there might be some underlying issue on the Linux file system level or it may be a Samba permissions mapping issue
> for the Cygwin user.
> UAC should not have been an issue, the account was in the local admins group,
> but having the mapping be remembered would make sense anyhow, I agree.
> (And running as the actual local administrator account may perhaps make some minute difference that the group membership
> doesn't bring.)

Actually, unless the cygwin user was a domain account rather than a
local machine account, I would be surprised if it was not receiving
the ghost "full control" I mentioned above.

>> > The symptoms begin with an error saying something like “Unable to extract
>> /etc/ -- the file is in use.” plus a suspicion about a corrupt package.
>> > Skipping past this error gives an almost identical error but about
>> > “/etc/postinstall”, and skipping that gives another about
>> “/etc/postinstall/”.
>> When was the most recent filesystems check on the host with the actual
>> files?  A corrupt directory tree can cause similar issues.
> Will do. Even if my immediate problem is solved, I think you may be right,
> there seems to be some lingering permissions issue that caused my confusion.
> Thanks again, even if my problem turned out to really be account/permissions-related,
> your answers might give some useful hints for others with similar problems.

You are very welcome  :)

-- Erik

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list