Windows 10/Cygwin setup.exe error - IO Error Opening File:

Jenny Pawlak
Sun Aug 14 10:50:00 GMT 2016

I am a new Windows 10 user and am trying to install Cygwin for the
first time (no prior Cygwin installation experience).  I didn't find
similar questions asked either on Cygwin or on StackOverflow.

Here is the problem:

1. Running Windows 10 Version 1607 (OS Build 14393.51) on a new laptop
with lots of disk space.  My account has administrator privileges.

2.  Downloaded setup-x86_64.exe (version 2.874) from

3.  Turned off firewall (McAfee LiveSafe) before running setup.exe.
(Just in case it helps; I am still running ByteFence)

4.  Using (I have tried others and
tried using multiple mirrors at once)

4.  I am accepting all the default packages plus some basic developer
stuff (gdb, make) and check "Select required packages (RECOMMENDED)".

5.  Cygwin setup works for maybe a minute and then gives the first of
many, many pop-up messages "IO Error Opening
file....._autorebase/binutils/cygwin/grep/mintty etc. Do you want to
skip this package?"

When I browse to indicated directory I find a *.tmp file in that
location  (e.g. base-files-4.2-4.tar.xz.tmp 44KB) and that the full
file was never fully downloaded.

I can abort setup.exe with the TaskManager and then re-run it again
and sometimes get a little bit further before getting the "IO Error
Opening file" message but, so far, I am unable to install an operable

I'd appreciate any help.

Thanks for taking the time to read this.


PS:  I have recently installed several unrelated programs from the
Internet without incident (e.g. git bash, notepad++).

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list