Cygwin-2.5.0 net share wbadmin no longer working post update

Alexandria Gutierrez
Thu Apr 14 14:37:00 GMT 2016

Hey team,

I run into an issues that I was unable to find assistance within the
archives or google searches.  I would appreciate some help to bounce a
few ideas to get this issues resolved. Thank you for your time in

We have a linux server that uses wbadmin via cygwin to backup a
windows node. After the cygwin-2.5.0 upgrade, our script stopped
working. Since we need this working continuously in our workplace, I
uninstalled cygwin and reinstalled back to 2.4.0 and the backup began
working again.  I used a second windows machine to install
cygwin-2.5.0 in order to test and troubleshoot on a system that can
afford to be down, this second machine is getting the same error.

It would appear that something in the new cygwin version changes the
way the that path is being interpreted within cygwin for wbadmin.
Below I will post a few examples of what is happening.

The original command that gets forwarded via ssh is the following:

/cygdrive/c/windows/Sysnative/wbadmin START BACKUP -user:USERNAME
-password:PASSWORD -backuptarget:"\\SERVERNAME\PATH\TO\SHARE"
-allCritical -systemstate -quiet

Which returns the following error:
ERROR - The user name or password is unexpected because the backup location
is not a remote shared folder.

The only changes in the linux node doing the backups and the windows
node being backup have been standard windows 2008R2 and redhat
Besides that nothing else has changed in either system

In my testing I confirmed the following things:
1) I am able to mount the samba share on the windows machine without any issues
2) the samba share has correct permission, and I was able to
read/write to the corresponding folders in the share
3) I am able to ssh in and out of the both unix and windows nodes
without any issues
4) windows and linux are able to resolve the SERVERNAME to the correct IP
5) added an extra \ (escape) to the path as following
\\\\SERVERNAME\\PATH\\TO\\SHARE, which returns the same error
6) I tried to setup a variable and then use cygpath without luck,
still getting the same error. using echo, I verified that the intended
path is being printed
7) verified that SERVERNAME and corresponding IP are located on
/etc/hosts on the cygwin installation

Here is where I noticed that the issue must have been related to cygwin:
Using the exact same same wbadmin command in the example above, and
running it on a windows terminal (cmd), the backup works just fine.
Then I open a cygwin terminal and type the exact same wbadmin command
and the I get the error again.

Since the same command works on a windows terminal but not in cygwin
is leading me believe this may be an issues with the new update.
I tested on the cygwin-2.4.0 system and both cygwin terminal and
windows terminal work correctly.

I hope I am missing something small, perhaps a config file requires a
minor change in order to resolve this issue.
Any help would be appreciated.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list