Octave segmentation fault when plotting graph -- dri-drivers

Marco Atzeri marco.atzeri@gmail.com
Tue Apr 12 12:52:00 GMT 2016

On 12/04/2016 14:24, Marco Atzeri wrote:
> On 12/04/2016 13:53, Stephen Wilkinson wrote:
>> Tatsuro: I tried to roll back to earlier version of Cygwin (all
>> packages) but that broke several other things.
>> Marco: I confirm that was broken for 32-bit. I've just installed
>> Cygwin 64-bit and Octave works as expected. I got crashes with fltk
>> and qt graphic toolkits, but I admit I didn't try gnuplot. All was
>> working fine until I updated -- I can't remember what version of
>> Octave I was running but 4.0.0 sounds about right.
>> Regards,
>> Steve
> I guess Tatsuro was thinking to revert only cygwin package to 2.4.1.
> I just tried and it makes no difference.
> the segfault seems in the X libraries
> #1  0x43934357 in gallium_dri!__driDriverGetExtensions_swrast ()
>     from E:/cygwin/lib/dri/swrast_dri.so

Reverting dri-drivers to 11.0.9-1 seems to solve the issue.

can you give a check ?


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list