Octave segmentation fault when plotting graph

Marco Atzeri marco.atzeri@gmail.com
Tue Apr 12 10:53:00 GMT 2016

On 12/04/2016 12:26, Stephen Wilkinson wrote:
> Following a recent Cygwin update, I get segmentation faults when I try to plot graphs in Octave. Creating the figure window works (i.e. issuing the command "figure" doesn't cause the crash, it is only when plotting within the figure that I get a crash). I use the Octave command "sombrero" to test the plotting of data, but even simpler commands ("plot(1:10,1:10);") cause the crash. The crash occurs whether using the fltk or qt graphics toolkit.
> I'm using:
> Octave: GNU Octave, version 4.0.1
> Cygwin: CYGWIN_NT-6.1-WOW OEM-9D7L362 2.5.0(0.297/5/3) 2016-04-11 09:55 i686 Cygwin
> The command I issue in Octave is:
>>> sombrero
> And I get this error message:
>>> panic: Segmentation fault -- stopping myself...
> attempting to save variables to 'octave-workspace'...
> save to 'octave-workspace' complete
> I ran strace to try to debug the problem. The strace output is too large (MB) to attach, but comparing strace for a normal termination of octave (run octave, create a figure but without plotting) and a segmentation fault termination of octave (run octave, issue command "sombrero"), I see that a segmentation fault causes "threads exited with status 0xc0000005". However I don't know how to debug this any further.
> I attach the output of cygcheck -s -v -r
> Any suggestions on how to debug this further or how to fix it would be very welcome! I have tried downgrading octave and qt but to no avail.
> Regards,
> Steve

confirmed for 32bit only. 64 bit version seems to work normally.

As workaround "graphics_toolkit gnuplot" does not crash, for what I see.

Did you ever had any problem on 4.0.0 ?


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list