Postinstall script errors

Ken Brown kbrown@cornell.edu
Mon Apr 11 18:51:00 GMT 2016


On 4/11/2016 11:49 AM, Kenneth Lobb wrote:
> Getting setup-x86_64.exe postinstall script errors, starting with
> /etc/postinstall/ca-certificates.sh.
>
> Script just hangs.

Is this the only postinstall script that gives you problems?  What 
happens if you rename it to ca-certificates.sh.done so that setup won't 
keep trying to run it.  Do the remaining scripts run OK?  If not, please 
take a look at /var/log/setup.log.full to see if you can tell why 
they're failing.

> Tried running ca-certificates.sh  manually, and the script just hangs.
>
> If I run individual commands, they complete normally whereas in the
> script they hang (don’t return control to the calling script).

Very strange.

Please follow the problem-reporting guidelines at 
http://cygwin.com/problems.html, including the part about attaching 
cygcheck output:

"Run cygcheck -s -v -r > cygcheck.out and include that file *as an 
attachment* in your report. Please do not compress or otherwise encode 
the output. Just attach it as a straight text file so that it can be 
easily viewed."

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list