Mintty font problem

john refling
Sun Apr 10 19:50:00 GMT 2016

Paul Ausbeck <paula <at>> writes:

> Cygwin setup just updated some older packages while installing a 
> requested new component and now mintty does not recognize fonts 
> properly. I was previously using lucinda-console but now some default 
> font is being used. When I try to change the mintty font through the 
> Options... dialog, the following message appears when I press Select...:
> "There are no fonts installed.
>   Open the Fonts folder from the Control Panel to install fonts."
> I've looked through the cygwin announce history and mintty v2.3.3 
> advertises some font support changes. I'm still running Windows XP on 
> this machine and I'm wondering if it could be that this new version of 
> mintty has not been tested on XP?

I'm having the same problem with a new XP install and cygwin, where it 
worked before.  Tried v 2.3.3, v2.3.5, and older archived v2.2.4 which 
certainly worked fine on previous XP machine.  Nothing works now, so not 
sure if it is mintty or XP setup.  Exact same XP install disk as previous.  
Different hardware.

One MS forum suggested to make sure that at least 1 printer was installed to 
make fonts visible in some applications.

Another suggested checking permissions on the font directory.

A cygwin forum suggested that there might be no monospace fonts installed 
and that mintty needs monospaced fonts only (make sense).

I've tried all the above, and no luck.

Something else suggested using tweakui to rebuild certain system folders.

I'll try that next.

John Refling

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list