cmake fails to run/build under Cygwin

Nick Kennedy dr.nick.kennedy@gmail.com
Mon Sep 21 11:11:00 GMT 2015


I've been trying to use cmake under Cygwin. Using the current binary
installed using Cygwin setup and running 'cmake .' from a folder that
contains a CMakeLists.txt just sits there with the process using 100% of a
core on my machine and nothing visibly happening otherwise. The CMakeFiles
folder is created but nothing is put into it, and no cache is ever created.

Running cmake without a path produces the appropriate usage message.

I've tried using both x86 and x86-64 versions of Cygwin.

I've also tried downloading from source the current version of cmake
(3.3.2) and the latest release of cmake 2 (2.8.12.2). In both cases, the
bootstrap script manages to build the cmake executable in the Bootstrap.cmk
folder, but then exhibits the same behaviour while 'loading initial cache
file InitialCacheFlags.cmake'. (For 2.8.12.2 I had to use the cmake.cygport
file from the relevant earlier commit on cygwin-ports).

I'm using Windows 10 running on a machine with a Core i7 and 12 GB of RAM.
Cygwin is otherwise working fine, and I'm able to build programs using
alternatives such as autotools.

I've attached the output of cygcheck. I've redacted my Microsoft account
name/email address (the line contains ###redacted### instead).

I'd be grateful for any help. I'm happy to post this to a kitware mailing
list too, but since the problem seems to be specific to Cygwin (and
includes the supplied Cygwin cmake binaries), I thought I'd start here.

Best wishes,

Nick
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 63240 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20150921/eedf3c11/attachment.obj>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list