Cygwin fork:retry error

Marco Atzeri
Wed May 27 22:25:00 GMT 2015

On 5/27/2015 11:16 PM, Gerry Reno wrote:
> I've been struggling with this fork:retry issue for over a month and have yet to find a working solution.
> The machines are Windows 7 64-bit with Cygwin 32-bit installation.

what about testing a 64bit cygwin installation ?

> I run Setup and then install some bash scripts for the user.
> Only some of the machines appear to be having this fork:retry problem.
> And even reinstalling Cygwin does not appear to fix the problem.
> Error:
>      /etc/profile: fork: retry: Resource temporarily unavailable
>       1 [main] bash 3236 child_info_fork::abort: C:\Cygwin\bin\cyggcc_s-1.dll: loaded to different address:
>      parent(0x370000) != child(0x2B0000)

this two addresses are very low. On my machine

$ rebase -si |grep cyggcc_s
                           base 0x5dc90000 size 0x00022000

So I suspect a BLODA is interfering with your cygwin installation.

  less /proc/self/maps

you can have an idea of which dll are loaded

> I've tried completely eliminating every trace of Cygwin I can find on the machine and then reinstalling Cygwin but the
> error persists.
> I've tried the rebaseall commands listed in a number of posts.  Again, the error persists.
> What's interesting is that if I try rebooting one of these machines numerous times eventually the scripts will work
> without this fork:retry error.
> But if you reboot the machine again most likely the fork:retry error will reappear.
> It's almost like there is some race condition involved.

An antivirus more likely

> Any help here greatly appreciated.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list