[ANNOUNCEMENT] Updated: Tcl/Tk 8.5.18

Steven Penny svnpenn@gmail.com
Thu May 21 00:30:00 GMT 2015


On Wed, May 20, 2015 at 4:41 PM, Yaakov Selkowitz wrote:
> * Just after the last Cygwin tcl/tk release, upstream decided to
> "improve" Cygwin support by further hybridizing it, going in the exact
> opposite direction we went with the switch to a fully *NIX/X11 8.5.  I
> have done my best to undo all these changes (which were extensive), but
> please let me know if something was missed.

Am I reading this right in that "tcl" and "tcl-tk" packages no longer require
X11? I would love it if we went back to using GDI, however I am seeing
unexpected results on a fresh setup.ini:

    @ tcl-tk
    sdesc: "Tcl X11 toolkit"
    ldesc: "An X11 toolkit implemented with the Tcl scripting language."
    category: Interpreters Tcl X11
    requires: bash cygwin libfontconfig1 libX11_6 libXft2 libXss1 tcl
    version: 8.5.18-1

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list