rpc/types.h: No such file or directory

Gery . gamejihou@hotmail.com
Tue May 19 18:16:00 GMT 2015


> Setting CFLAGS/CPPFLAGS/CXXFLAGS in the bash shell before invoking make 
> should just work. This has always worked when using the GNU autoconf 
> too lchain paradigm of building projects. So there may be something 
> about your particular build system that is not picking up these 
> changes. So you'll have to figure out how to propagate these 
> downstream to the actual compiles. 
> 
> Tom 

Thanks Tom, I've been changing the path in the #include directive of xdr.h and types.h in /usr/include/tirpc/rpc, as well as in the MBsystem include files, and now it starts picking the rpc/types.h calls, so MBsystem software is compiling. It just stops compiling and throws the same error in files that don't have the full path in the #include directives (ie. /usr/include/tirpc/rpc/types.h instead of rpc/types.h). Having said that, you're right about propagating these changes to actual compiles this software. I agree, bash shell should do the job, it would be great if someone knows the trick and can share it here. 		 	   		  
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list