cygport partially broken by recent updates ?

Marco Atzeri marco.atzeri@gmail.com
Mon May 11 21:35:00 GMT 2015


On 5/11/2015 8:07 PM, Yaakov Selkowitz wrote:
> On Sun, 2015-05-10 at 11:52 +0200, Marco Atzeri wrote:
>> I just noted that cygport seems not anymore able to
>> produces debug info nor is correctly identifying
>> package own dll's
>
> Did you install this singular-debuginfo then try to package it again?
>
> --
> Yaakov
>

It is not that. I have both cases.
I rebuild both versions today with the same system condition,
same result.
Old version has debuginfo, new version does't.
The DLL's in the build tree have similar size, and both have debuginfo

This from the version with no debuginfo:
$ objdump -h Singular/dyn_modules/syzextra/.libs/syzextra.dll

Singular/dyn_modules/syzextra/.libs/syzextra.dll:     file format pei-x86-64

Sections:
Idx Name          Size      VMA               LMA               File off 
  Algn
[cut]
                   CONTENTS, ALLOC, LOAD, READONLY, DATA
  10 .debug_aranges 00001450  00000005f0bcc000  00000005f0bcc000 
00034800  2**0
                   CONTENTS, READONLY, DEBUGGING
  11 .debug_info   000b0164  00000005f0bce000  00000005f0bce000 
00035e00  2**0
                   CONTENTS, READONLY, DEBUGGING
  12 .debug_abbrev 00003ddc  00000005f0c7f000  00000005f0c7f000 
000e6000  2**0
                   CONTENTS, READONLY, DEBUGGING
  13 .debug_line   0000f4a7  00000005f0c83000  00000005f0c83000 
000e9e00  2**0
                   CONTENTS, READONLY, DEBUGGING
  14 .debug_frame  00006b68  00000005f0c93000  00000005f0c93000 
000f9400  2**3
                   CONTENTS, READONLY, DEBUGGING
  15 .debug_str    00003afa  00000005f0c9a000  00000005f0c9a000 
00100000  2**0
                   CONTENTS, READONLY, DEBUGGING
  16 .debug_loc    000727e6  00000005f0c9e000  00000005f0c9e000 
00103c00  2**0
                   CONTENTS, READONLY, DEBUGGING
  17 .debug_ranges 00021d50  00000005f0d11000  00000005f0d11000 
00176400  2**0
                   CONTENTS, READONLY, DEBUGGING


Comparing both config.status I only notice that the last one has
an additional LDFLAGS portion in config.status

    -rdynamic -Wl,-undefined,dynamic_lookup

It seems the only build difference. Ideas what to check ?

Regards
Marco



--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list