Problems with screen on Windows 10 Preview system

Stephen John Smoogen
Sat May 2 00:05:00 GMT 2015

I downloaded and installed a copy of Windows 10 on a spare system to
see how Cygwin works. Most of the applications worked similarly to
what I was testing on my Windows 7 system. However I have run into a
problem with the screen command.

The first time I run screen the command gives me a standard help
screen and data. If I type exit to get back to mintty and then
type screen again.. I get:

Directory '/tmp/uscreens' must have mode 777.

Which after going through the faq and old mailing list was
something that occurred on FAT partitions. So I went to check the
install and the file format is NTFS. I then looked at /tmp and

drwx---rwt+ 1 smoog smoog 0 May 1 16:01 uscreens

I went to try and change the permissions with chmod and got no
change in perms or errors. [Looking at the various posts on
this.. I am not to expect any errors.]

I then tested screen on my Windows 7 system and it worked
properly with the permissions on the directory as:

drwxrwxrwt+ 1 smooge None 0 May 1 17:01 uscreens

The umask of the user is 0022 on both systems.

Any suggestions on how I can further debug this?
Thank you

Stephen J Smoogen.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list