Aw: Re: Xwin 1.17.2.1 exits early

Rainer Blome rainer.blome@gmx.de
Wed Jul 29 17:50:00 GMT 2015


 
Gesendet: Mittwoch, 29. Juli 2015 um 18:14 Uhr
Von: "Jon TURNEY"
> I think this is saying that using the start menu shortcuts doesn't work,
> but I'm not sure.

Yes, a few months ago, they stopped working for me.
For my report this is "merely" context, although I would appreciate it if they worked.

On 28/07/2015 16:43, Rainer Blome wrote:
>> * I tried leaving out all command-line args but "-multiwindow". Still no success.

> How about leaving out all command-line args completely?

Same symptoms, exits after less than a second with same output (didn't diff, though).

>> * I used the Cygwin installer to roll back to 1.17.1.5. Still no success.

> This tends to argue against that you were using 1.17.1-5 previously, or
> that other things e.g. the cygwin DLL were upgraded at the same time.

Yes, I may have come to 1.17.2 from a release earlier than 1.17.1-5

To be able to work, I installed VcXsrv which has "1.17.0.0" in its version string.
That mostly works fine, except that it refuses connections from remote SSH-X-forwarding clients
(did not try to troubleshoot that yet, it's just been a few hours).

>> How can I troubleshoot this further?

> Can you provide the logfile written by 'strace -o logfile XWin -multiwindow' which might shed some light.

Yes, attached.

Regards, Rainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: strace-XWin-multiwindow-RB.log
Type: text/x-log
Size: 95433 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20150729/cfe7179f/attachment.bin>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list