Xwin exits early

Rainer Blome rainer.blome@gmx.de
Tue Jul 28 15:43:00 GMT 2015

First off: I have been using Cygwin for about 15 years now,
thanks to the maintainers!!!

For a few months now, the only way for me to get Cygwin/X to run
was to start a Cygwin terminal ("C:\cygwin\bin\mintty.exe -i /Cygwin-Terminal.ico -"),
then run "XWin -multiwindow -clipboard" from there, in the foreground.
That has worked for many weeks now.

Today, I upgraded from 1.17.1-5 to 1.17.2-1 (I think),
and XWin no longer starts as it used to.
No X icon appears, XWin exits almost immediately, with return code zero.

This is the output:
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-6.1-WOW ************ 2.1.0(0.287/5/3) 2015-07-14 21:26 i686
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (WoW64)
Package: version 1.17.2-1 built 2015-07-09

XWin was started with the following command line:

Xwin -multiwindow

(II) xorg.conf is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
LoadPreferences: /cygdrive/c/blome/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000005

* The machine is not loaded, has plenty of RAM and works fine otherwise.
* I used dash -> /usr/bin/rebaseall -v, and
  feel stupid actually jumping through this particular type of hoop.
  Still no success.
* I rebooted MS Windows. Still no success.
* I disabled the firewall. Still no success.
* I tried leaving out all command-line args but "-multiwindow". Still no success.
* I searched the internet for some of the messages,
  especially the "xorg.conf is not supported" one. Nothing appropriate.
* I read some of the FAQ (searched for "xorg.conf" in it). Nothing appropriate.
* I looked at the past two months of mailing list. Nothing appropriate.
* I used the Cygwin installer to roll back to Still no success.

With Version 1.17.1-5, the package version differed, of course:

 Package: version 1.17.1-5 built 2015-06-02

and there were additional messages like this,
which may have ben caused by the downgrade:

 Could not load crashreporter dll

Other than that, the output was the same.

* I also tried the startxwin script, which not surprisingly,
  gives the above messages plus these:

 xinit: giving up
 xinit: unable to connect to X server: Connection refused
 xinit: server error

How can I troubleshoot this further?


PS: My expectation is this:

In Cygwin installer, select newest package xorg.server, install,
accept suggested set of additional packages to install (dependencies),
opt to create shortcuts.
Start X11 server via the new shortcut,
an X icon appears in the "system tray" (lower right-hand corner).
Right-click the X icon, start X11 apps from there.
At some point a few years back (at least 2012), this actually worked.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list