Python bindings for cygclang.dll causing segmentation fault on 64 bit system

Brad Elliott
Fri Jul 24 15:25:00 GMT 2015

Hi there,

I'm running into difficulties which I think are caused by cygclang.dll. The problem only seems to impact the 64 bit version of Cygwin. The 32 bit version of Cygwin (on my 64 bit machine) does not crash. I tried running the same thing on Windows 7 and Windows 8 but both OSes are impacted. I also tried a fresh installation of 64 bit Cygwin and encountered the same issue.

I'm running this command which causes Python 2.7.10 to seg fault. 

 > python hello.c
 > Segmentation fault (core dumped)

I can't figure out how to use the stackdump as it looks like I need to re-build Python with debug symbols turned on and I haven't investigated that yet.

The script comes from the CFE bindings examples. I actually extracted the version for the sources for 3.5.2 but there appear to be no differences between that version and the latest:

The hello.c file is very simple
 > $ cat hello.c
 > &include <stdio.h>
 > &include <stdlib.h>
 > int main(void)
 > {
 >  return 0;
 > }

I did report this to but I'm not sure if this issue is a Cygwin problem or an LLVM problem:


-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 64779 bytes
Desc: not available
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: hello.c
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: python2.7.exe.stackdump
Type: application/octet-stream
Size: 1378 bytes
Desc: not available
URL: <>
-------------- next part --------------
Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list