SIGINT generated by Control-C, is not delivered in mintty

Ronald Fischer ynnor@mm.st
Wed Jul 15 08:24:00 GMT 2015


On Tue, Jul 14, 2015, at 11:27, Achim Gratz wrote:
> Ronald Fischer <ynnor <at> mm.st> writes:
> > Using Cygwin 64 on Windows 7:
> > 
> > In a bash or zsh running inside mintty, pressing Control-C has no
> > effect.  In a bash or zsh running in a Windows Console, it works fine.
> > 
> > This can be verified in two ways:
> > 
> > (1) Using 'trap':
> > 
> > In the shell, we do a
> > 
> >   trap 'echo trapped' INT
> > 
> > Now whenever we hit Control-C, we expect "trapped" to be printed on
> > stdout. This is not the case when the shell runs inside mintty.
> > 
> > (2) Using 'cat':
> > 
> > In the shell, we do a
> > 
> >   cat
> > 
> > which has the effect that cat reads from stdin. A control-C should abort
> > it. Again, this doesn't work when we run inside mintty.
> 
> WJFFM.  Make sure that the stuff in GW (GNUwin?) and Linux64 does not
> interfer.  Also, you have multiple cygwin1.dll on your path (p/nano), fix
> that and see if it makes any difference.

Good point, but did not help:

I have removed the GNUwin Utilities and the path to my second
cygwin1.dll from my PATH (which is a good idea anyway), verified it, and
repeated the test - same result.

Next - to be really sure that we don't have any interference - I did a

   PATH=/usr/bin mintty

and inside mintty did a

  echo $PATH

to verify, that I really have only /usr/bin in my PATH, and here too,
the same effect - Control-C not delivered.

BTW, the last time I worked with mintty (on a different project) - it
was about 3 years ago - it worked fine, so I guess the bug sneaked in
recently.

Ronald

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list