stow-2.2.0-1 modules installs to [...]/site_perl/5.10 in 2.0.4 x86

Thomas Stenhaug thomas.stenhaug@gmail.com
Sun Jul 12 11:46:00 GMT 2015


The corresponding package in 2.0.4 x86_64 installs correctly, however.
Following are two shell transcripts to demonstrate.  First one from
2.0.4 x86

  $ uname -a
  CYGWIN_NT-6.1-WOW laspezia-win7 2.0.4(0.287/5/3) 2015-06-09 12:20 i686 Cygwin

  $ cygcheck -c stow
  Cygwin Package Information
  Package              Version        Status
  stow                 2.2.0-1        OK

  $ stow -V
  Can't locate Stow.pm in @INC (@INC contains:
/usr/lib/perl5/site_perl/5.14/i686-cygwin-threads-64int
/usr/lib/perl5/site_perl/5.14
/usr/lib/perl5/vendor_perl/5.14/i686-cygwin-threads-64int
/usr/lib/perl5/vendor_perl/5.14
/usr/lib/perl5/5.14/i686-cygwin-threads-64int /usr/lib/perl5/5.14 .)
at /usr/bin/stow line 418.
  BEGIN failed--compilation aborted at /usr/bin/stow line 418.

  $ cygcheck -l stow | grep site_perl
  /usr/lib/perl5/site_perl/5.10/Stow/Util.pm
  /usr/lib/perl5/site_perl/5.10/Stow.pm

And then on from 2.0.4 x86_64

  $ uname -a
  CYGWIN_NT-6.1 laspezia-win7 2.0.4(0.287/5/3) 2015-06-09 12:22 x86_64 Cygwin

  $ cygcheck -c stow
  Cygwin Package Information
  Package              Version        Status
  stow                 2.2.0-1        OK

  $ stow -V
  stow (GNU Stow) version 2.2.0

  $ cygcheck -l stow | grep site_perl
  /usr/lib/perl5/site_perl/5.14/Stow/Util.pm
  /usr/lib/perl5/site_perl/5.14/Stow.pm

What should I do to fix this?


Regards,
Thomas Stenhaug

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list