Vim, Mintty, and mouse resizing no longer works.

Thomas Wolff towo@towo.net
Sat Jul 11 21:13:00 GMT 2015


Am 11.07.2015 um 23:07 schrieb James Darnley:
> On 2015-07-11 22:44, Thomas Wolff wrote:
>> Am 11.07.2015 um 20:11 schrieb James Darnley:
>>> On 2015-07-11 13:59, Thomas Wolff wrote:
>>>> Am 11.07.2015 um 02:52 schrieb James Darnley:
>>>>> Hi Thomas
>>>>>
>>>>> Unfortunately I have a complaint to make.
>>>>>
>>>>> When using the latest Mintty release I can no longer use the mouse to
>>>>> resize split windows in Vim.  In 1.1.3, I can drag any window separator
>>>>> around to change the size of them.  In 2.0.2 Aim appears to interpret
>>>>> the mouse as trying to make a visual section in one window.
>>>>>
>>>>> I tried quickly to narrow down which commit might have introduced the
>>>>> problem using git bisect, unfortunately it was slowed down by some
>>>>> commits not compiling.  However it did lead to producing this message.
>>>>>
>>>>>> 4765275a7cfd9fadc74aedc1191de5390fa11c09 is the first bad commit
>>>>>> commit 4765275a7cfd9fadc74aedc1191de5390fa11c09
>>>>>> Author: Thomas Wolff <mintty@users.noreply.github.com>
>>>>>> Date:   Tue Jun 16 14:45:20 2015 +0200
>>>>>>
>>>>>>        fix restructuring
>>>>> If I checkout the commit immediately preceding this the mouse works
>>>>> as I
>>>>> expect.  I cannot explain why this might be the case as it looks like
>>>>> there are no relevant code changes in that commit.
>>>>>
>>>>> I will try to investigate some more but I wanted to let you know.
>>>> The commit you refer to did not change any actual code, so maybe
>>>> something in the environment is involved.
>>>> Please describe a reproducible test case. How would you setup split
>>>> windows in vim? How would you try to resize them?
>>>> Also, did you use one of the new mouse options, like MiddleClickAction?
>>>> Thomas
>>> I don't know if you know vim so this might be verbose.
>>>
>>> To make a vertical split, run the command :vs
>>> To open vim with a vertical split: vim -O file1 file2
>>> (That is a literal colon, v, and s and an uppercase letter O)
>>>
>>> To make a horizontal split, run the command :sp
>>> To open vim with a vertical split: vim -o file1 file2
>>> (That is a literal colon, s, and p and an lowercase letter O)
>>>
>>> To resize (when it works) just left click on the separator and drag.
>>> Much like resizeable frames in a web page or a Windows window border
>>> (but you don't get the double ended arrow cursor)
>> Hi James,
>> thanks for the step-by-step description. I cannot reproduce, however, a
>> working resize. I've tried with mintty 1.1.3 (freshly compiled, should
>> that make a difference) on cygwin-32, and mintty 1.2 on cygwin-64.
>> With a horizontal split, vim does not show me any separator at all.
>> With a vertical split, there is a vertical bar ("|") separator, but
>> nothing happens on click-and-drag. Is some additional vim configuration
>> needed to enable that feature? General mouse enabling perhaps? (I once
>> heard this would need to be fiddled about in vim and emacs and I wonder
>> why these traditional editors make basic things so troublesome for the
>> users; my own editor, mined, provides all mouse functions
>> out-of-the-box...)
>> Please, additional details.
>> Regards,
>> Thomas
> Ah yes, there is a config option for the mouse.  Actually a bit of quick
> testing shows that two are needed.  You can either run these two command
> or set them in vimrc.
> :set nocompatible
> :set mouse=a
OK, I had found the mouse=a option meanwhile and reproduced the issue 
and found the problem.
If I only patch the apparently non-working version of mintty to report 
version 1.2 and change nothing else,
it works! This is obviously a bug in vim, not mintty, and a very silly 
one, because if must be checking the terminal version and enable the 
feature only if major version == 1 or something like that (rather than 
 >= 1).
Please report to vim.
Thomas

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list