Telnet / SSH connection timeout on LAN

Joseph B joseph.buchignani@gmail.com
Mon Jul 6 19:03:00 GMT 2015


Hi Andrew,

Desktop

LAN Adapter
IP: 192.168.0.2 (static)
Subnet Mask: 255.255.255.0
no DNS server

Wifi Adapter
192.168.254.18 (dynamic)
255.255.255.0
gateway: 192.168.254.254

Laptop

LAN
192.168.0.1 (static)
255.255.255.0
no DNS

Wifi
192.168.254.19 (dynamic)
255.255.255.0
192.168.254.254

I don't think these namespaces overlap?

Note that my ethernet cable is standard 5e, not crossover. I am
directly wiring the computers without a switch or hub. This is not
supposed to work, and indeed it doesn't work very well. I am content
at this point to use wifi's slower transfer speed, since the big 250
GB transfer is done. So I would rather stop using the ethernet cable,
as it is a likely failure point.

Testing with ethernet cable only, wifi disabled on both:

I re-attached the ethernet cable. After manually changing the network
type from "public" to "private (work)" on both computers, I was able
to access Windows shared folders, as before. Network is still labeled
"unidentified" on both machines, as before.

Synctoy runs about the same. It finishes the 250 GB sync with about
1000 errors. Not sure whether it's faster; maybe.

Cygwin ping works from laptop to desktop. It sends 4 packets, time 0 ms.
  However, from desktop to laptop, it sends 13 successful pings
averaging .5 ms and then freezes. It never presents the statistical
summary. Ctrl-c does not break the loop. Had to restart the Cygwin
window.
I did not observe this behavior before. Ping from desktop windows CLI
succeeds normally.

Cygwin telnet fails to cross the cable both ways, with error "unable
to connect to remote host: Connection timed out". Telnetting localhost
gives "connection refused". I don't know how to set up a telnet
server.

Cygwin ssh to localhost / ip address succeeds. E.g. "ssh localhost"
 Connection to other machine fails with error "connect to host
192.168.0.x port 22: Connection timed out". Command was e.g. "ssh
192.168.0.1"

Thanks for the advice. Please let me know what to do next. Adieu.

On Mon, Jul 6, 2015 at 10:26 AM, Andrey Repin <anrdaemon@yandex.ru> wrote:
> Greetings, Spinfusion!
>
>> My goal:
>> To set up rsync over SSH, to sync my org-mode GTD files, activated every
>> time my laptop or pc goes idle, as described by Gina Trapani.
>
>> Network hardware architecture:
>> Windows 7 laptop and desktop, connected directly by cat 5e ethernet cable.
>> Also both connected via wifi to the same router.
>
> What are assigned IP addresses on both links?
> Your further hints indicate that you have name resolution conflict due to
> overlapping network address space.
> Disconnect from WiFi on both hosts and try only cable.
>
>> Network functionality:
>> Windows firewalls currently disabled
>> Windows shared folders works for directory browsing and editing
>> Synctoy worked to sync drives, although it spewed a lot of errors and took a
>> long time and many retries to sync ~250 gb. Did it over the ethernet cable
>> because wifi was too slow.
>
>> Cygwin functionality:
>> ping works.
>> telnet error: connection timed out
>> ssh error: connection timed out
>> ssh connection to localhost - works
>
>> Background and guesses:
>
>> I've read and tried many fixes with no luck, to the best of my limited
>> understanding.
>
>> I doubt network names are configured correctly; I'm out of my depth there.
>> Pinging works with fixed IP addresses assigned for the ethernet connection.
>
>> I don't know what I'm doing and would appreciate some guidance. Cheers.
>
>
> --
> With best regards,
> Andrey Repin
> Monday, July 6, 2015 18:24:38
>
> Sorry for my terrible english...
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list