Failure in merging win-env vars into post-'login'...

Linda Walsh
Mon Jan 26 11:51:00 GMT 2015

Corinna Vinschen wrote:

> - Can you please start inetd under strace, once under 1.7.33, once under
>   the 1.7.34 test DLL and then log in as you usally do?  This requires
>   some patience because under strace the whole process of logging in
>   will become almost unbearably slow.
	~20 seconds?

>   With the test DLL, you can stop
>   immediately after the password prompt shows up. 
I trimmed both of the traces in gvim to the point when they
both first call "-bash".

I *was* able  to login *with* my password under the test release.
It placed me in the same home directory -- so I ran getent there
as well:
Bliss\law:unused:5013:201:L A Walsh, Trust Technologies,,U-Bliss\law,S-1-5-21-33333-77777-33333-5013:/Users/law.Bliss:/bin/bash

I think that is the same output as before.

>    I take it you're
>   starting inetd from the command line of a local session, right?
Usually from WIN-R (run) since I don't have a local window open yet
until I run inetd -- but that's still a local session, so should
be the same, just not the same as a startup from bash or a command line.

>   The setup is dead simple then: 
>     $ strace -o inetd-1.7.33.trace inetd [your inetd options] 
>     $ strace -o inetd-1.7.34.trace inetd [your inetd options]
No options are passed in.  The only file I think I needed to change
was '/etc/inetd.conf' (also attached).

Other than that the binaries need to be installed (doy!)...
Both traces are attached in xz format.

>   Then send the traces, please, compressed and attached.

> - Can you give me a short, concise description how you set up
>   inetd/rlogin so I can try to reproduce this locally?
	Just the /etc/inetd.conf.. my 'terminal client'
then uses the rlogin protocol and feeds it my systemname
(localhost didn't work, but the shortname 'athenae' does)
and my Userid 'Bliss\law'.

If you want to try the same terminal client,
you can download it for a 30-day trial

I am not running under the latest release as my
'free updates' expired (I'm running 7.1.1 x64 version,
current is 7.3).  Note: when you purchase, you get
free updates for some period after that, but the
client itself doesn't it's been a pretty
good value (you can set it for normal scrolling or
jump scrolling.. among many other configurables).

Hope this was everything ... ?

> Thanks,
> Corinna
-------------- next part --------------
A non-text attachment was scrubbed...
Name: inet733.trc.xz
Type: application/octet-stream
Size: 33064 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: inet-1.7.34.trc.xz
Type: application/octet-stream
Size: 36676 bytes
Desc: not available
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: inetd.conf
URL: <>
-------------- next part --------------
Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list