[ANNOUNCEMENT] TEST RELEASE: Cygwin 1.7.34-003 (Christmas/New Year release)

Corinna Vinschen corinna-cygwin@cygwin.com
Wed Jan 21 10:20:00 GMT 2015

On Jan 21 02:45, Andrey Repin wrote:
> Sorry for the holdup, I was trying to crack it by myself.
> But I was unsuccessful, and have to reach for help.
> Even the most striped down configuration doesn't produce visible improvements.
> The setup: A Win7 machine - member of a NT4-style domain. (No AD yet.)
> Logged in as domain user with admin rights.
> Current profile path is C:\Users\<username>.<domainname>
> group/passwd files are moved away.
> Contents of nsswitch.conf (the last, stripped down next to nothing attempt):
> passwd: db
> group: db
> db_home: /%H
> db_shell: /bin/sh
> > set HOME
> HOMEPATH=\Users\anrdaemon.CCENTER
> > getent passwd %USERNAME%
> anrdaemon:*:1051576:1049089:U-CCENTER\anrdaemon,S-1-5-21-1031481445-3291699540-3997755762-3000:/home/anrdaemon:/bin/bash
> If I understand it right, the /%H should always return usable value, so do
> /bin/sh. But I can't get it to work.

Weird, really.  I just tried it again myself and it worked immediately.

What I'm doing is this:

- I'm *not* running cygserver.
- Open a mintty.
- Change the nsswitch.conf settings and save the file.
- Start another mintty to observe the effect.

If cygserver is not running, every new mintty session will see the
latest version of the nsswitch.conf file and create the passwd/group
entries from there.

I'm wondering if that's a side effect of using a NT4 domain.  This isn't
supported in Cygwin anymore for quite some time.  After all AD has
replaced NT4 15 years ago.  All the LDAP calls to fetch the AD attributes
won't work in an NT4 domain, for instance.

But even if all the calls to the DB fail, the /path scheme shouldn't be

For a start, can you run `strace -o getent.trace getent passwd anrdaemon
in a mintty session started *after* changing nsswitch.conf and send the
getent.trace file?  It might give some clue.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20150121/7e69b2df/attachment.sig>

More information about the Cygwin mailing list