slow startup after upgrade

Roger Orr rogero@howzatt.demon.co.uk
Tue Feb 24 21:22:00 GMT 2015


Hello Corinna,
It seems slightly faster than the previous patch and I've not noticed a
downside yet.


CYGWIN_NT-6.1-WOW LCLDN-DEV24 1.7.35s(0.286/5/3) 20150220 15:47:55 i686
Cygwin:

~37ms to run echo.exe from Windows command prompt
~60ms to run .\id.exe -a from Windows command prompt

CYGWIN_NT-6.1-WOW LCLDN-DEV24 1.7.35s(0.286/5/3) 20150223 21:02:38 i686
Cygwin: 

~35ms to run echo.exe from Windows command prompt
~53ms to run .\id.exe -a from Windows command prompt

nsswitch.conf: passwd and group both set to 'db'

Regards,
Roger.

-----Original Message-----
From: Roger Orr [mailto:rogero@howzatt.demon.co.uk] 
Sent: 23 February 2015 23:33
To: 'cygwin@cygwin.com'
Subject: RE: slow startup after upgrade

Hi Corinna,
sounds good. I'll give this a go, all being well, tomorrow.

In other news it appears that the ADInsightDll uses some shared data to
communicate, so in order to get ADInsight to work with injection one has to
ensure that the DLL injected is the same actual *file* as the one loaded by
the ADInsight program (in the (windows) %TEMP% directory) - a copy of the
DLL doesn't seem to be effective.

Regards,
Roger.

-----Original Message-----
From: Corinna Vinschen [mailto:corinna-cygwin@cygwin.com] 
Sent: 23 February 2015 21:16
To: cygwin@cygwin.com
Cc: Roger Orr
Subject: Re: slow startup after upgrade

Hi Roger,

On Feb 16 20:02, Roger Orr wrote:
> Corinna Vinschen wrote:
> > So I'd think the best way forward is to update to the
> > 1.7.35-0.1 test release and report further from there.     
> 
> Thanks, this does help a little. However I will still be using the 'files'
> setting.
> 
> Here are some results in case they're of interest. (Windows 7/64 with
> cygwin/64.)
> 
> 1) Running cygwin "echo.exe" from a cmd.exe command shell
> 
> a) With passwd: files and group: files in /etc/nsswitch.conf
>   0.03 - 0.4 s
> 
> b) With 1.7.34 and default /etc/nsswitch.conf
> 
>   around 120s
> 
> C) With 1.7.35 and default /etc/nsswitch.conf
> 
>   4.4 - 4.6s

I rewrote the function responsible for the slow startup, the one
fetching all the group information for the groups in your user token.

As I just wrote in my mail to Dennis Hagarty, the performance improvement
should be noticable, even with /etc/nsswitch.conf only using the "db"
setting for groups.  The group info for a user token with 150 groups was
fetched in ~50 ms rather than the ~300ms of the former code.

Can you test this again with the Cygwin DLL from the latest developer
snaphshot at https://cygwin.com/snapshots/ please?


Thanks,
Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list