TEST RELEASE: Cygwin 1.7.35-0.3

Andrey Repin anrdaemon@yandex.ru
Tue Feb 24 09:07:00 GMT 2015

Greetings, Warren Young!

>>> Is there any solution to solve the ssh problem ( including git etc)?
>> Does https://cygwin.com/faq/faq.html#faq.using.ssh-pubkey-stops-working
>> help?

> That information seems to be incomplete.

> I ran into similar problems here, and found that chmod 600 would give me
> mode 660 *if* the files were in my “Warren” group as well as owned by me, personally.

> I fixed it with chgrp None ~/.ssh/*

> It seems that chmod 600 is being interpreted as:

> 1. It’s owned by Warren, so +rw for him.

> 2. Oh, its primary group is Warren, too, so let’s inherit g+rw, too.

Nop, this is actually an issue of reading ACLs rather than setting them.
POSIX access bits do not expect interchangeability of users and groups.

> Sorry for not reporting it earlier.  I thought I had just de-weirded something local.

Andrey Repin (anrdaemon@yandex.ru) 24.02.2015, <06:37>

Sorry for my terrible english...

More information about the Cygwin mailing list