TEST RELEASE: Cygwin 1.7.35-0.3

Warren Young wyml@etr-usa.com
Tue Feb 24 03:50:00 GMT 2015

> On Feb 23, 2015, at 1:11 PM, Corinna Vinschen <corinna-cygwin@cygwin.com> wrote:
> On Feb 24 03:50, rexdf Rexdf wrote:
>> Is there any solution to solve the ssh problem ( including git etc)?
> Does https://cygwin.com/faq/faq.html#faq.using.ssh-pubkey-stops-working
> help?

That information seems to be incomplete.

I ran into similar problems here, and found that chmod 600 would give me mode 660 *if* the files were in my “Warren” group as well as owned by me, personally.

I fixed it with chgrp None ~/.ssh/*

It seems that chmod 600 is being interpreted as:

1. It’s owned by Warren, so +rw for him.

2. Oh, its primary group is Warren, too, so let’s inherit g+rw, too.

Sorry for not reporting it earlier.  I thought I had just de-weirded something local.
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list