bug in csih?

Corinna Vinschen corinna-cygwin@cygwin.com
Mon Feb 23 15:57:00 GMT 2015

On Feb 23 13:05, Corinna Vinschen wrote:
> On Feb 20 18:32, Len Giambrone wrote:
> > Running the latest version:
> > 
> > $ cygcheck -c cygwin openssh csih
> > Cygwin Package Information
> > Package              Version        Status
> > csih                 0.9.8-5        OK
> > cygwin               1.7.34-6       OK
> > openssh              6.7p1-2        OK
> > 
> > When I run
> > 
> >    ssh-host-config -y -w XXXXX
> > 
> > 
> > I get this:
> > 
> > *** Query: Create new privileged user account 'WX64LG\cyg_server' (Cygwin
> > name: 'cyg_server')? (yes/no) yes
> WX64LG is the local machine, right?  If you're in a domain, the Cygwin
> name should have been "WX64LG+cyg_server", not just "cyg_server".

I just tried that myself and that's what I see:

*** Info: This script plans to use 'cyg_server'.
*** Info: 'cyg_server' will only be used by registered services.
*** Query: Do you want to use a different name? (yes/no) no
*** Query: Create new privileged user account 'VMBERT8164\cyg_server' (Cygwin name: 'vmbert8164+cyg_server')? (yes/no)

See that the Cygwin username is "vmbert8164+cyg_server"?  That's the
expected result on a dmain member machine.

Sorry, I don't see how it's possible that the csih script came up with
"cyg_server" alone in your case, unless it's a domain controller.
In theory, this piece of code in
/usr/share/csih/cygwin-service-installation-helper.sh does the trick:

Function csih_select_privileged_username(), line 2869ff:

    if ! csih_use_file_etc "passwd"
      # This test succeeds on domain member machines only, not on DCs.
      if [ "\\\\${COMPUTERNAME,,*}" != "${LOGONSERVER,,*}" ]
        # Lowercase of USERDOMAIN

The only reason this didn't work would be if the test

      if [ "\\\\${COMPUTERNAME,,*}" != "${LOGONSERVER,,*}" ]

didn't have the desired result, but I don't see why that would occur.
Any chance you can find out what happened in your scenario?


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20150223/8b869028/attachment.sig>

More information about the Cygwin mailing list