Very slow Cygwin startup on Windows 7

Corinna Vinschen corinna-cygwin@cygwin.com
Thu Feb 19 12:15:00 GMT 2015


On Feb 19 09:49, Dennis Hagarty (dehagart) wrote:
> Hi Corinna,
> 
> >>>Can you please try this test version without cygserver, and with
> >>>the passwd and group settings in /etc/nsswitch.conf set to
> >>>
> >>>  passwd: db
> >>>  group: db
> >> 
> >>> It would be very interesting to know if this improves the situation for you.
> >> 
> >> Just did it for 1.7.35-0.2 - I haven't seen 0.3 turn up at a mirror site yet.
> 
> >It's only just uploaded so it might take another while, depending
> >on your mirrors.  According to Roger's results in
> >https://cygwin.com/ml/cygwin/2015-02/msg00511.html and
> >https://cygwin.com/ml/cygwin/2015-02/msg00543.html, the real problem
> >hadn't been fixed in the 0.2 test release, so you might give 0.3
> >another chance.
> 
> BTW - I did try ADInsight, but it didn't show me anything (maybe because this is a 64 bit windows?)
> 
> Anyway, I ran it with 0.3 and nsswitch = db and the result is???
> 
> 1.68-1.72 seconds

Hmm.  No offense, but are you sure you ran this with 0.3?

> With nsswitch = files db it was 1.43-1.45 seconds.
> 
> With nsswitch = files it was 0.13-0.14 seconds
> 
> (It seems basically the same as 0.2)

It would be pretty helpful to get an idea what's so slow in your case.
Either you get ADInsight working, or...  is it ok if I send you a link
to a debug-augmented DLL via PM?


Thanks,
Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20150219/2e28aeb8/attachment.sig>


More information about the Cygwin mailing list