Very slow Cygwin startup on Windows 7

Dennis Hagarty (dehagart)
Wed Feb 18 11:56:00 GMT 2015

>>>Could you please do me a favor and repeat the test with a little deviation of
>>>my previous suggestion?

>>>1. Remove /etc/{nsswitch.conf,passwd,group} files. (Rename, move away - by
>>>your choice.)
>>>2. Stop cygserver, if it is running, and any other Cygwin-related programs.
>>>3. Start the mintty (elevated, if need) with write access to /etc. Supposedly,
>>>this will be slow.
>>>4. Make sure id -G lists all the groups you're member of.
>>>The `id -znG | tr "\0" "\n"` would probably be more visible.
>>>5. Repeat the steps from previous suggestion.
>>>    getent passwd $(id -u) > /etc/passwd
>>>    getent group $(id -G) > /etc/group
>>>    printf "%s\n" "passwd: files db" "group: files db" > /etc/nsswitch.conf
>>> 6. Close and restart mintty

>> After I'd run the id -znG, it found 87 groups.
>> Then I did this (even with cygserver running)

>> ~ getent passwd $(id -u) > /etc/passwd
>> ~ getent group $(id -G) > /etc/group
>>       0 [main] getent 48156 transport_layer_pipes::connect: lost connection to cygserver, error = 2

>That prompts to repeat the previous question from Corinna: are you by chance
>remote from your DC? (VPN connection?)

Yes - although it's pretty quick link (and not the other side of the world).
Seems to be a node called  \\ADC-AER1-C1-2 

Pinging [] with 32 bytes of data:
Reply from bytes=32 time=36ms TTL=124
Reply from bytes=32 time=44ms TTL=124
Reply from bytes=32 time=37ms TTL=124
Reply from bytes=32 time=56ms TTL=124

>> ~ wc -l /etc/group
>> 58 /etc/group
>> Since it seems like cygserver stopped, it took a while to complete.
>> Anyway, with cygserver stopped, I ran the getent again elevated and got 83.
>> ~ wc -l /etc/group
>> 83 /etc/group
>83 vs. 87, still not the right number.
>> Not really sure how many groups I'm a member of (in another tool), but seems about right.

>Anyway, how was the results after these manipulations?

Performance now is good - as long as the cygserver is running.
>cmd /v:on /c "echo !TIME! & C:\cygwin64\bin\mintty.exe /bin/echo "test" & echo !TIME!"
12:13:43.65 = 0:00.12

C:\Users\dehagart>cmd /v:on /c "echo !TIME! & C:\cygwin64\bin\mintty.exe /bin/echo "test" & echo !TIME!"
12:16:24.85 = 1:48.57


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list