postinstall script errors for package chicken

Christian Kellermann ckeen@pestilenz.org
Fri Feb 13 14:42:00 GMT 2015


Hi Volker,

Thanks for your feedback! I do need further information (see below).

vzell@volkerzell.de (Dr. Volker Zell) writes:
> For both architectures chicken postinstall scripts fail.
>
> 32-bit:
> =======
>
> 2015/02/08 14:46:54 running: C:\cygwin\bin\bash.exe --norc --noprofile "/etc/postinstall/chicken.sh"
>
> Error: (require) cannot load extension: setup-download
> 2015/02/08 14:46:54 abnormal exit: exit code=70
> 2015/02/08 14:46:55 can't run /etc/postinstall/dconf.sh: No such file

I have identified and fixed this issue and I am about to release another
version. However:

>
> 64-bit:
> =======
>
> 2015/02/08 15:18:16 running: C:\cygwin64\bin\bash.exe --norc --noprofile "/etc/postinstall/chicken.sh"
> usage: chicken-install [OPTION | EXTENSION[:VERSION]] ...

I cannot reproduce this with my chicken-4.9.0.1-2 package. the content
of that postinstall script should be:

--8<---------------cut here---------------start------------->8---
#!/bin/bash
chicken-install -update-db
--8<---------------cut here---------------end--------------->8---

Can you tell me if that's the case on your machine?
If you change it to that and rerun it, does it work then?

Thanks!

Christian

-- 
May you be peaceful, may you live in safety, may you be free from
suffering, and may you live with ease.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list