[ANNOUNCEMENT] Updated: Cygwin 1.7.34-6

Corinna Vinschen corinna-cygwin@cygwin.com
Fri Feb 6 10:36:00 GMT 2015

On Feb  5 12:07, gjnospam2014-cygwinproblems@yahoo.com wrote:
> This update appears to break the no-X emacs daemon.  Specifically, the
> process seems to hang, gettingas far as displaying
> "Starting Emacs daemon." but not (visibly) further.  If you start an
> emacsclient from a different window, it is unable to find/connect to 
> the server.  If you are trying to start the server using
> $ emacsclient -t --alternate-editor=""
> then it will just sit there.

I can't reproduce this.  Note that I'm not an emacs user.  What I do:

In one mintty I start emacs and pressed M-x server-start.

In a second mintty I run `emacsclient -t --alternate-editor=""'.  I get
the typical emacs buffer window.  I can type some text and press C-x 5 0
and this exits emacs.

Then I run `emacsclient -t --alternate-editor=""' again, and emacs starts
with a buffer filled with the text I typed in the first client session.

Looks entirely normal to me, as far as I can judge this as emacs noob.

> Reverting to cygwin-1.7.33 "fixes" it.

Ken, can you take a look, perhaps?  I'm just not familiar enough with


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20150206/40a1c538/attachment.sig>

More information about the Cygwin mailing list