CTRL-C does not work in Cygwin when using pipes

Michael Enright mike@kmcardiff.com
Wed Dec 30 09:11:00 GMT 2015

On Wed, Dec 30, 2015 at 1:03 AM, Michael Enright  wrote:
> On Tue, Dec 29, 2015 at 2:57 PM, Michael Enright  wrote:
>> And since I have chosen to participate in this thread, I tried the
>> command in question. The success of my attempt does not mean that I
>> don't believe there's a problem. My setup is Windows 7/64 in a VM,
>> running 32-bit cygwin, mintty terminal and bash.
> Also Windows 10 (not yet updated to November update) 64-bit running
> 64-bit Cygwin, minty and bash was okay.
> Also, for fun, I tried this in Power Shell
>> $env:Path += ";C:\cygwin64\bin"
>> bash
> $ perl -e 'while(1) {sleep 1;}
> I was able to control-C out of this.
> (And now we all know the way to augment the path in Power Shell!)
> Not a recommended way to use Cygwin tools but I thought it was worth adding.

Okay on review the above is not faithful to the problem statement and
so I tried some variations:
In bash inside Power Shell,
 echo foo | perl -e 'while(1) {sleep 1;}'
Will hang.

The same command pipeline, under the condition of having the path
augmented as above, will perform as expected and control-C will stop
the program.

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list