fork issue when lauching cygwin64 process from 32bit native app on Windows 10 TH2

Rob van Eijk
Tue Dec 1 19:33:00 GMT 2015

Op 1-12-2015 om 17:40 schreef David Macek:
> On 1. 12. 2015 15:01, Corinna Vinschen wrote:
>> On Dec  1 21:07, nu774 wrote:
>>>> There must be a bug in the new CMD somewhere.  But, anyway, I'll look
>>>> into it when I finally managed to update my W10 test machine.
>>> No, cmd.exe is just an example. Any 32bit process can be an trigger.
>>> I guess something has changed in TH2 kernel regarding process memory
>>> management or something that interferes cygwin's fork().
>> If that only happens w/ 64 bit Cygwin started from a 32 bit parent, then
>> there's some foul-up in the WOW64 layer in terms of starting 64 bit
>> processes, perhaps.  Sigh, it's a rather unexpected change after it
>> worked fine for so long :(
> Yup. I can confirm.

I upgraded today to Windows 10 v1511. I ran into the same problem. I
renamed my cygwin root directory (64 bit) and installed a 32 bit version
of cygwin. The fork problem does not appear on the 32 bit version.

In conclusion, I confirm that the issue appears when running a 32 bit
version from a 64 bit cygwin. It does not appear when running a 32 bit
app from a 32 bit cygwin.

PS: my test applicatin is notepad++ with the nppexec plugin, which I use
to power up the make command in a cygwin shell.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list