vi editing at bash command line: cc command doesn't work

Mon Sep 8 23:14:00 GMT 2014

<Paul.Domaskis> writes:
> I needed cygwin on a new work computer that was locked down.  I
> created a DVD from all the 64-bit packages some time in the first
> quarter of 2014, then took the several months needed to get approval
> for its installation.  I then replicated the environment from an old
> work computer with a 32-bit installation of cygwin, including:
>    ~/.inputrc
>    ~/.minttyrc
>    ~/.bash_profile
>    ~/.bashrc
>    /usr/share/vim/vimrc
>    /usr/share/vim/vimfiles
> Everything works well *except* for the fact that when using vi-like
> editing at the bash command line, the cc command does not clear the
> line and enter insert mode.  This is the same regardless of whether
> I am using a mintty or an xterm in X-windows.  However, if I invoke
> vim from either of those 2 environments, cc does work.  It also
> works when I run gvim from xterm, and when I run gvim compiled for
> Microsoft Windows.
> What more can I check to try and narrow down the cause of the
> problem?
> Below, I have pasted in anonymized content from the above files.


Please note that when I say cc doesn't work with vi-editing at the
bash command line, I mean that nothing happens.

Also, I did not clean up the vimrc file because I suspect that there
is very little chance that it was the culprit.  I believed that
nothing from vimrc is used for vi-editing at the command line.  I
confirmed this just now by renaming /usr/share/vim/vim{rc,files} and
observing the same problem with vi-editing at the command line.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list