any ssh for android that can connect to cygwin's sshd?

Fri Sep 5 22:24:00 GMT 2014

On Friday, 5 September 2014, 16:18, Richard <> wrote:

On Fri, 5 Sep 2014, Marilo wrote:
>> I am able to connect to a server running Cygwin's sshd from a computer running debian openssh.. or from >>a computer running cygwin. So the server is set fine. If the key fails it prompts for a password, i've >>set the server's sshd_config is set like that.
>> But the Android apps that i've tried e.g. 'better terminal' and perhaps juicessh, tend to use Dropbear ssh, and dropbear ssh gives an error when trying to connect. It says
>> ssh: Connection to user@host:123 exited: 
>> No matching algo hostkey
>> maybe the encryption algorithms don't match, but i'm no expert
>> Is there anything I can do at cygwin's sshd end.. Or, any command line ssh client for android that is known to be able to connect to it?

>I use something called "Terminal-IDE".

>One big problem with what you want to do is with the keyboard and 
>Terminal-IDE provides a full keyboard solution... Check it out...


Terminal IDE does indeed have a great keyboard, it installs it and then it's available for any terminal app.  Though I see it uses dropbear ssh and gives the same error as better terminal. (in fact, better terminal has a slightly later version of dropbear ssh that includes a -v option), nevertheless.. both are dropbear ssh and give the same error when going to cygwin sshd.  Though clearly you guys don't get the error. 

Here is a screenshot of a packet capture is my phone, and is the cygwin sshd server.

Though it( phone), is fine connecting to bitvise sshd on  or to a linux machine And to rule out my WLAN, the one other computer on my WLAN can connect to my cygwin sshd server.

I tried moving the cygwin sshd server to port 22 instead of 222. But same error from ssh, and packet capture still showed TCP Dup ACK  and I see TCP Retransmission.. but also, this time I see from the packet capture screenshot here, that it got as far as some SSH protocol. But still same error at same point, from dropbear ssh on my mobile.  I don't have another device running dropbear ssh to try.

I will try reinstalling cygwin on the machine in question. And i'll try turning the router off and on first

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list