autorebase failed for unknown package

Stephen Dewey stepheneliotdewey@gmail.com
Mon Oct 6 23:24:00 GMT 2014


Here is the contents of autorebase.bat. I don't know much about
rebasing or batch files so I may be way off base (heh), but should
"dash" be "bash"?

@echo off
rem Postinstall scripts are always started from the Cygwin root dir
rem so we can just call dash from here
path .\bin;%path%
dash /bin/rebaseall -p

On Mon, Oct 6, 2014 at 7:16 PM, Stephen Dewey
<stepheneliotdewey@gmail.com> wrote:
> Hi there,
>
> I have spent a while attempting to solve this myself, but I apologize
> for anything obvious I may have missed. I am getting the following
> messages for both Cygwin and Cygwin64 on my laptop:
>
> Package: Unknown package
> autorebase.bat exit code 1
>
> Here are details that may narrow it down.
>
> 1. They were previously working without this message, which I
> encountered when updating to get the Shellshock bug fix.
> 2. I then performed a full uninstall / reboot / confirm no Cygwin
> processes / reinstall, first of Cygwin64 and then Cygwin32 but still
> saw the issue.
> 3. I used the default minimum package lists.
> 4. I tried two different mirrors with the same result.
> 5. I also tried "reinstall" of all selected package with the same result.
>
> Thanks for any additional troubleshooting suggestions you can provide.
>
> I tried to attach my full setup logs, but it causes me to exceed the
> spam score threshold for this mailing list. Nothing jumps out at me,
> but here's the message with some context:
>
> 2014/10/06 18:59:44 running: C:\cygwin\bin\bash.exe --norc --noprofile
> "/etc/postinstall/coreutils.sh"
> 2014/10/06 18:59:44 running: cmd.exe /c
> "C:\cygwin\etc\postinstall\autorebase.bat"
> 2014/10/06 18:59:44 abnormal exit: exit code=1
> 2014/10/06 18:59:44 running: C:\cygwin\bin\bash.exe --norc --noprofile
> "/etc/postinstall/base-files-mketc.sh"
>
> Stephen

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list